2019-10-23 12:44 EDT


View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003014FSSCPgraphicspublic2016-12-11 20:37
ReporterKobrar 
Assigned ToDahBlount 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSWindows 7 HP 64bitOS Version
Product Version3.7.1 
Target VersionFixed in Version 
Summary0003014: Environmental reflections are wrong
DescriptionSo it is a bug originally reported on the forum in thread:
http://www.hard-light.net/forums/index.php?topic=87019.msg1739006#msg1739006
Basically, some of the coordinates of the cubemap seem to be flipped.

Testcase here: https://www.mediafire.com/?s1rcbe6pcoi1o1q
Steps To Reproduce1.Let the engine produce his own cubemap[at least from cube skybox].
2.Watch the reflection on some reflective object.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0015803

Goober5000 (administrator)

Am I to understand that this is now fixed?

~0015804

niffiwan (developer)

Last edited: 2014-06-05 20:50

View 2 revisions

Did you mean to assign this one to me? I am an OGL neophyte...

Edit: ok - just some confusion due to me misnaming a commit on github - this one isn't fixed as far as I know.

~0016295

Goober5000 (administrator)

Last edited: 2014-09-24 02:42

View 2 revisions

Removing the 3.7.2 tag since I only added that because I thought niffiwan had fixed it. :)

~0016759

Echelon9 (developer)

I'll have a go looking at this one.

~0016791

DahBlount (developer)

Pull request to fix this is now available.
https://github.com/scp-fs2open/fs2open.github.com/pull/466

~0016796

niffiwan (developer)

This is fixed now?

Also - can haz DahBlount 'developer' status?

~0016797

MageKing17 (developer)

The final PR that should have fixed this: https://github.com/scp-fs2open/fs2open.github.com/pull/468

Until DahBlount gets dev status, I've unassigned this from Echelon9 and I'm marking it fixed.

~0016798

Kobrar (reporter)

As seen here: https://www.youtube.com/watch?v=OO4cxEh-kqk
There are still some issues

~0016800

DahBlount (developer)

Looking further into this, turns out the inverse matrix4 function wasn't even required. Removing the function call in gropengltnl.cpp gives proper results simply with the changes to the texture_mat setup in gropengltnl.cpp and freespace.cpp as well as an additional change in the main vertex shader to normalize the eye position.

~0016802

MageKing17 (developer)

This should finally be fixed for real now: https://github.com/scp-fs2open/fs2open.github.com/pull/499
+Notes

-Issue History
Date Modified Username Field Change
2014-03-05 15:54 Kobrar New Issue
2014-06-05 20:31 Goober5000 Note Added: 0015803
2014-06-05 20:31 Goober5000 Assigned To => niffiwan
2014-06-05 20:31 Goober5000 Status new => code review
2014-06-05 20:31 Goober5000 Target Version => 3.7.2
2014-06-05 20:41 niffiwan Note Added: 0015804
2014-06-05 20:50 niffiwan Note Edited: 0015804 View Revisions
2014-06-05 20:50 niffiwan Assigned To niffiwan =>
2014-06-05 20:50 niffiwan Status code review => new
2014-09-23 23:16 niffiwan Description Updated View Revisions
2014-09-24 02:42 Goober5000 Note Added: 0016295
2014-09-24 02:42 Goober5000 Target Version 3.7.2 =>
2014-09-24 02:42 Goober5000 Note Edited: 0016295 View Revisions
2015-06-26 07:24 Echelon9 Note Added: 0016759
2015-06-26 07:24 Echelon9 Assigned To => Echelon9
2015-06-26 07:24 Echelon9 Status new => assigned
2015-11-22 17:59 DahBlount Note Added: 0016791
2015-12-06 01:56 niffiwan Note Added: 0016796
2015-12-06 04:53 MageKing17 Note Added: 0016797
2015-12-06 04:53 MageKing17 Assigned To Echelon9 =>
2015-12-06 04:53 MageKing17 Status assigned => resolved
2015-12-06 04:53 MageKing17 Resolution open => fixed
2015-12-07 16:58 Kobrar Note Added: 0016798
2015-12-07 16:58 Kobrar Status resolved => feedback
2015-12-07 16:58 Kobrar Resolution fixed => reopened
2015-12-12 19:05 DahBlount Note Added: 0016800
2015-12-15 09:23 MageKing17 Note Added: 0016802
2015-12-15 09:23 MageKing17 Status feedback => resolved
2015-12-15 09:23 MageKing17 Resolution reopened => fixed
2016-12-11 20:37 Goober5000 Assigned To => DahBlount
+Issue History