2018-11-21 16:56 EST


View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0002590FSSCPgameplaypublic2012-07-24 06:06
Reporterniffiwan 
Assigned Toniffiwan 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.6.14 RC6 
Target Version3.6.14Fixed in Version3.6.14 
Summary0002590: Starting Wings are allowed to have 6 ships which causes crashes when restarting the mission
DescriptionThe wings in $Starting Wings: are allowed to have 6 ships. However the ship & loadout selection screens assume a maximum of 4 ships per wing. This causes issues with the loadout screen itself, as well as causes the mission to crash on restart.

A simple option would be to not allow missions with more than MAX_WING_SLOTS (4) ships in starting wings to parse. A more complicated option (& a feature) would be to increase MAX_WING_SLOTS to 6.
Steps To ReproduceGet clippingtest.fs2 from the RC4 release thread.
http://www.hard-light.net/forums/index.php?topic=79747.msg1579245#msg1579245
(or see attached to this

Open the mission in the simulator and switch to the ship selection screen.
Note that "Gamma Wing" only has two ships and one is locked.

Start the mission, press escape and select "restart mission". FSO will crash.
Additional InformationWe should provide an updated mission in the RC4 thread before we stop this mission from parsing. Otherwise we're shooting ourselves in the foot regarding testing of the new sound code.
TagsNo tags attached.
Attached Files

-Relationships
related to 0002653resolvedkarajorma MAX_WING_SLOTS warning is triggering on a wing of 4 ships. 
+Relationships

-Notes

~0013220

niffiwan (developer)

Fix committed to trunk@8413.

~0013309

Zacam (administrator)

Fix committed to fs2_open_3_6_14@8484.

~0013565

karajorma (administrator)

Fix committed to trunk@8795.

~0013760

Zacam (administrator)

Fix committed to fs2_open_3_6_14@8936.

~0013832

niffiwan (developer)

I think that karajorma's fix has re-introduced the original bug :( This is a reminder for me to review this...

~0013882

niffiwan (developer)

derp - j will be out of bounds when slot is assigned after j has reached MAX_WING_SLOTS... needs another fix

~0013885

niffiwan (developer)

Should be fixed in r9052
+Notes

-Related Changesets
fs2open: trunk r8413
Timestamp: 2012-02-01 04:23:05
Author: niffiwan
Ported: N/A
Details ] Diff ]
Fix for mantis 0002590: fix array overruns caused by starting wings have > MAX_WING_SLOTS ships
mod - /trunk/fs2_open/code/missionui/missionshipchoice.cpp Diff ] File ]
mod - /trunk/fs2_open/code/missionui/missionscreencommon.cpp Diff ] File ]
fs2open: fs2_open_3_6_14 r8484
Timestamp: 2012-02-13 19:48:41
Author: Zacam
Ported: N/A
Details ] Diff ]
Backport: Trunk r8413; Fix for mantis 0002590: fix array overruns caused by starting wings have > MAX_WING_SLOTS ships
mod - /branches/fs2_open_3_6_14/code/missionui/missionshipchoice.cpp Diff ] File ]
mod - /branches/fs2_open_3_6_14/code/missionui/missionscreencommon.cpp Diff ] File ]
fs2open: trunk r8795
Timestamp: 2012-05-18 22:28:41
Author: karajorma
Ported: N/A
Details ] Diff ]
Niffiwan's fix for 2590 seems to have introduced a bug of it's own. Easy enough to fix it though.
mod - /trunk/fs2_open/code/missionui/missionshipchoice.cpp Diff ] File ]
fs2open: fs2_open_3_6_14 r8936
Timestamp: 2012-07-01 21:02:07
Author: Zacam
Ported: N/A
Details ] Diff ]
Backport: Trunk r8795; Niffiwan's fix for 2590 seems to have introduced a bug of it's own. Easy enough to fix it though.
mod - /branches/fs2_open_3_6_14/code/missionui/missionshipchoice.cpp Diff ] File ]
fs2open: trunk r8995
Timestamp: 2012-07-06 21:39:27
Author: niffiwan
Ported: N/A
Details ] Diff ]
Fix number 3 for mantis 0002590 - move array overflow detection to correct place in loops
mod - /trunk/fs2_open/code/missionui/missionscreencommon.cpp Diff ] File ]
mod - /trunk/fs2_open/code/missionui/missionshipchoice.cpp Diff ] File ]
fs2open: fs2_open_3_6_14 r9033
Timestamp: 2012-07-23 21:37:42
Author: Zacam
Ported: N/A
Details ] Diff ]
Backport: Trunk 8995; Fix number 3 for mantis 0002590 - move array overflow detection to correct place in loops
mod - /branches/fs2_open_3_6_14/code/missionui/missionscreencommon.cpp Diff ] File ]
mod - /branches/fs2_open_3_6_14/code/missionui/missionshipchoice.cpp Diff ] File ]

+Related Changesets

-Issue History
Date Modified Username Field Change
2012-01-28 21:51 niffiwan New Issue
2012-01-28 21:51 niffiwan File Added: clippingtest.fs2
2012-01-28 21:52 niffiwan Assigned To => niffiwan
2012-01-28 21:52 niffiwan Status new => assigned
2012-01-28 23:41 niffiwan Description Updated View Revisions
2012-02-01 04:22 niffiwan Changeset attached => fs2open trunk r8413
2012-02-01 04:22 niffiwan Note Added: 0013220
2012-02-01 04:22 niffiwan Status assigned => resolved
2012-02-01 04:22 niffiwan Resolution open => fixed
2012-02-13 19:48 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8484
2012-02-13 19:48 Zacam Note Added: 0013309
2012-05-18 22:27 karajorma Changeset attached => fs2open trunk r8795
2012-05-18 22:27 karajorma Note Added: 0013565
2012-07-01 21:01 Zacam Changeset attached => fs2open fs2_open_3_6_14 r8936
2012-07-01 21:01 Zacam Note Added: 0013760
2012-07-05 09:07 niffiwan Note Added: 0013832
2012-07-05 09:07 niffiwan Status resolved => feedback
2012-07-05 09:07 niffiwan Resolution fixed => reopened
2012-07-05 09:07 niffiwan Relationship added related to 0002653
2012-07-05 09:07 niffiwan Status feedback => assigned
2012-07-06 21:37 niffiwan Changeset attached => fs2open trunk r8995
2012-07-06 21:39 niffiwan Product Version 3.6.14 RC4 => 3.6.14 RC6
2012-07-06 21:39 niffiwan Status assigned => resolved
2012-07-06 21:39 niffiwan Fixed in Version => 3.6.14
2012-07-06 21:39 niffiwan Resolution reopened => fixed
2012-07-23 21:32 Zacam Changeset attached => fs2open fs2_open_3_6_14 r9033
2012-07-23 23:25 niffiwan Note Added: 0013882
2012-07-23 23:25 niffiwan Status resolved => feedback
2012-07-23 23:25 niffiwan Resolution fixed => reopened
2012-07-24 06:06 niffiwan Note Added: 0013885
2012-07-24 06:06 niffiwan Status feedback => assigned
2012-07-24 06:06 niffiwan Status assigned => resolved
2012-07-24 06:06 niffiwan Resolution reopened => fixed
+Issue History