2018-03-20 14:11 EDT

View Issue Details Jump to Notes ] Related Changesets ]
IDProjectCategoryView StatusLast Update
0001658FSSCPgameplaypublic2012-07-01 01:56
Assigned ToGoober5000 
PlatformAny?OSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001658: More elegant exception handling for Undocked containers.
DescriptionFound a way to always create a M$ crash for an unhandled exception. It's rather easy to do. Would it be possible to create an error handling routine for it?

Can anyone confirm it occuring under Linux or OS X?
Steps To ReproducePick a mission, any mission that has Freighters with cargo containers attached.
Or, create one.

Set the $Name for the Freighter to be: GTFR Freighter. (Just an example, if you pick an egisting mission, add a letter or something AND update ALL Events or Goals that refer to the old name)

Create appropriate cargo container entry. Set +Docked With: Freighter. (Also just an example, just as long as the name in +Docked With does not match an existing Ship name)

Seems kind of simple, but it is an easy mistake if your not using FRED for what ever reason to make or modify a mission, and it can be really hard to track down because you have nothing useful to go off of.

Ironically, having two cargo containers "Docked" with the same ship causes no problem.

Having two ships with identical names also causes no problems.

Having two ships with the same name and two cargo containers Doced with that name, causes no problems.
Additional InformationThis same example will also crash FRED 100% of the time as well with an Error Report and no information provided by -debug builds.

Atleast if a ship is mis-named where Events or Goals are unable to find a ship of that name, you get a break into the debug telling you this.
TagsNo tags attached.
Attached Files

duplicate of 0001781closedGoober5000 FRED crashes if a mission is lacking a referenced object or variable 



Goober5000 (administrator)

1) Why on earth aren't you using FRED?

2) I really can't follow what you're trying to do. Why don't you attach a mission with your modifications.


Zacam (administrator)

What I did was make a mistake while editing in notepad that allowed for me to consistantly produce a failure.

Simplified gist: Make a cargo container that is docked with a ship that doesn't exist. Result: Crash. (And in windows, a request to send an error report to M$.)

As for not using FRED:
1: They don't notice notepad at my work, I write scripts.
2: I've never really liked it.
3: I don't really need it.


chief1983 (administrator)

Closing since 1781 has a better description of the problem.


Goober5000 (administrator)

Reopening since I'm not convinced these bugs are duplicates.


chief1983 (administrator)

Aww. They sound so similar. Oh well, good eye then Goob.


Goober5000 (administrator)

There is now more elegant exception handling. :)

If you have another bug issue with duplicate ships sharing the same name, feel free to open another ticket. The docking stuff should at least be fixed.

+Related Changesets

-Issue History
Date Modified Username Field Change
2008-04-10 05:16 Zacam New Issue
2008-04-17 22:07 Goober5000 Note Added: 0009232
2008-04-18 04:21 Zacam Note Added: 0009233
2008-09-27 02:15 Goober5000 Status new => assigned
2008-09-27 02:15 Goober5000 Assigned To => Goober5000
2008-10-09 13:10 chief1983 Relationship added related to 0001781
2008-10-09 13:12 chief1983 Relationship replaced duplicate of 0001781
2008-10-09 13:13 chief1983 Note Added: 0009900
2008-10-09 13:13 chief1983 Status assigned => closed
2008-10-09 13:13 chief1983 Resolution open => duplicate
2008-10-09 14:34 Goober5000 Note Added: 0009903
2008-10-09 14:34 Goober5000 Status closed => acknowledged
2008-10-09 14:34 Goober5000 Resolution duplicate => open
2008-10-09 16:49 chief1983 Note Added: 0009911
2012-07-01 01:55 Goober5000 Changeset attached => fs2open trunk r8922
2012-07-01 01:56 Goober5000 Note Added: 0013743
2012-07-01 01:56 Goober5000 Status acknowledged => resolved
2012-07-01 01:56 Goober5000 Resolution open => fixed
+Issue History