Source Code Project Mantis - FSSCP
View Issue Details
0001906FSSCPsoundpublic2009-04-02 18:352009-04-30 19:53
Reporterchief1983 
Assigned ToGoober5000 
PriorityimmediateSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version3.6.9 
Target VersionFixed in Version3.6.10 
Summary0001906: -voicer broken in trunk
DescriptionI've built a exe with FS2_VOICER and FS2_SPEECH (or whatever the speech define is). Speech seems to be working fine but when enabling the -voicer option the build throws an error "Failed to create the command recognition context". Hitting ok (which might be difficult if you're running in full screen mode) pops up another window, "Failed to init voice rec". Hitting ok for that continues as normal but I'm assuming voice recognition isn't working after that. Additionally, no debug log information is output for this process so there's not much else I can say. HerraTohtori had a similar experience on his Vista box, and I reproduced this on an XP32 box so far. This is surprising since the voicerec code has hardly been touched in 2 years.
Additional InformationIt could be a compiling issue, but the project file I used is now in SVN for inspection under MSVC_6_Release. It's nearly identical to the other MSVC6 one, but I've uploaded the speech SDK 5.1 and set it to use the include and lib folders now in SVN, plus I've enabled the Speech and Voice Recognition flags by default, and added profiles for Inferno builds. So not sure what would have gone wrong compiling.
TagsNo tags attached.
related to 0000848resolved Goober5000 Voice Recognition Feature Broken 
Attached Files

Notes
(0010797)
chief1983   
2009-04-03 12:39   
The first error message happens if Speech Recognition is not running/has not been set up. The error message changes to "Failed to load resource" if speech recognition is in place. Second error is the same.
(0010817)
Goober5000   
2009-04-22 13:18   
I vaguely remember running into a problem like this a few years ago. It turned out that it *was* a build problem, but I forget what it was.
(0010820)
chief1983   
2009-04-22 14:15   
Well I don't think I'm going to end up figuring it out, and unless someone else does we're not going to have working voice recognition any time soon. I'll keep trying some stuff in the meantime.
(0010860)
Goober5000   
2009-04-30 19:53   
It's a silly old problem with #define in the resource file; I ran into it two years ago too. It's fixed in revision 5189.

Issue History
2009-04-02 18:35chief1983New Issue
2009-04-03 12:39chief1983Note Added: 0010797
2009-04-07 16:51chief1983Priorityhigh => immediate
2009-04-22 13:18Goober5000Note Added: 0010817
2009-04-22 14:15chief1983Note Added: 0010820
2009-04-30 19:53Goober5000Note Added: 0010860
2009-04-30 19:53Goober5000Assigned To => Goober5000
2009-04-30 19:53Goober5000Statusnew => resolved
2009-04-30 19:53Goober5000Resolutionopen => fixed
2009-04-30 19:53Goober5000Fixed in Version => 3.6.10
2009-04-30 20:00Goober5000Relationship addedrelated to 0000848